Mein erster Spindel-Treiber treibt nicht

Nach einiger Planung habe ich die letzten Tage nach bestem Wissen und mithilfe der LPKF-Schaltpläne einen Umrichter für die HF-Spindel konzipiert und gebastelt. Probieren geht über studieren! dachte ich mir. Der „Umrichter“ besteht aus drei halben H-Brücken aus 6x BUZ21 MOSFETs, die mithilfe von 6x 1N4004 Dioden gegen Umkehrströme geschützt sind. Gesteuert wird diese Endstufe über 6 Pins von einem Arduino, jeder Pin hinter einem 180 Ohm Widerstand vor Überstrom geschützt. Die Komponenten sind auf eine 5 cm x 5 cm Lochstreifenplatine gelötet.

Bei Inbetriebnahme der Schaltung mit einer 500 ms Verzögerung zwischen An- und Ausschalten der Windungspaare an einer geregelten 15 Volt-Spannungsquelle gab die Spindel ein deutliches Surren von sich, drehte sich jedoch augenscheinlich nicht. Als die Spannung auf 30 Volt hochgeregelt wurde, wurde das Surren lauter, aber die Spindel drehte sich weiterhin nicht. Der Strom durch die Schaltung stieg an, sichtbar am Aufleuchten der Strombegrenzungs-LED der Spannungsquelle. Das Surren wurde nach ca. 10 Sekunden leiser und verschwand. Die MOSFETs fühlten sich unwesentlich erwärmt an, die Dioden nicht. Ich änderte die Verzögerung auf 1 ms. Die Spannungsquelle zeigte einen Kurzschluss an, daher schaltete ich aus und maß die Schaltung nocheinmal durch. Dabei musste ich feststellen, dass alle drei Spindel-Kanäle, alle Drain- und Source sowie die Spannungsquellen-Kanäle gegeneinander keinen Widerstand mehr hatten. Als ich die Schaltung aus dem Aufbau entfernte (um eine Diode von der Schaltung zu entfernen), bestand wieder ein Widerstand zwischen allen Drain- und Source-Kanälen (ca. 5 Mega-Ohm in Durchlassrichtung der Dioden, nicht-leitend in Sperrrichtung).

Nun stelle ich mir mehrere Fragen:

  • War/Ist eine Komponente defekt ? Welche und warum ?
  • Hat sich die geschädigte Komponente „regeneriert“ oder nur „abgekühlt“ aber ist trotzdem unbrauchbar ?

Eine intakte 1N4004 hat in Durchlassrichtung einen Widerstand von 4,7 Mega-Ohm, nicht-leitend in Sperrrichtung. Ein intakter BUZ21 hat zwischen D und S in Sperrrichtung einen Widerstand von 9,5 Mega-Ohm, nicht-leitend in Durchlassrichtung. Möglicherweise sind die 1N4004 nicht geeignet für Hochfrequenz-Anwendung. Vielleicht schalten die FETs auch nicht schnell genug, sodass Kurzschlüsse zwischen Ein- und Ausgang desselben Spindel-Anschlusses auftreten.

773 mal insgesamt angesehen, 2 mal heute angesehen.
Dieser Beitrag wurde unter Arduino, CNC veröffentlicht. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.